Amigaforum

Please login or register.

Login with username, password and session length
Advanced search  

News:

SMF - Just Installed!

+- +-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Stats ezBlock

Members
Total Members: 149
Latest: rufus
New This Month: 2
New This Week: 2
New Today: 0
Stats
Total Posts: 1304
Total Topics: 314
Most Online Today: 67
Most Online Ever: 119
(November 08, 2014, 04:06:23 PM)
Users Online
Members: 0
Guests: 65
Total: 65
Pages: [1]   Go Down

Author Topic: Linux probs on x1000 Southern Islands  (Read 75 times)

0 Members and 1 Guest are viewing this topic.

vox

  • Jr. Member
  • **
  • Karma: +2/-3
  • Posts: 99
    • View Profile
Linux probs on x1000 Southern Islands
« about: April 19, 2017, 10:41:14 AM »

Hi gents!

A bit late and resistant but finally purchased Enhancer and Radeon 7000HD (since W3D for Radeon 6000HD, Timberwolf updated and promise of Libre port have turned me on to buy x1000).

I still find it morally degrading to buy FE, Enhancer and new video card to get system bugfixed
and Warp3D ready (since we have prepaid OS 4.2, RadeonHD driver of that time and x1000 was
sold as "system" but sic, gfx cards in that system were to complex to 3D support), but hey, its Amiga.

On AmigaOS side things got brighter with Enhancer, but Linux side has been challenging.

a) Seems most of net installs, x1000 Ubuntu 12 CD etc. were all built for NI cards. Mostly Linuxes install, but fail to bring GUI. Kernel loads, everything looks OK, init gui and ... they are stuck. And those are x1000 supported. Out of stock netinstall initrd.gzs usually fail at partition time, unable to read partitions.

b) I have managed to install only older Debian 7 net install, however in KDE 4.x even with Compiz install it does not have OpenGL

c) Not everything is equal to CFE. I am unable to boot kernel from affs (old file system)
BDH0: or from EXT2 Linux boot partition. Is ide0.1:vmlinuz enough or somehow should
pont to SDB5

CF card is out now, had probs with 4GB one, AOS was unable to read 4GB FAT16
and CFE would also quirk rendering it unreadable from time to time. Switching
back to old good 128MB.

One sidenote, I do have classic HDD as data slave and SDD as primary.
I am aware that x1000 cant boot from every other device.

Also when expanding memory, take note that memory size needs to be set in
CFE (see memory= in printenv variables). Sad sad and buggy CFE.
Logged
Pages: [1]   Go Up
 

+-SMF Gallery Random Image

Recent Topics ezBlock

Amiga Future Everywhere: Android App erschienen by AndreasM
April 20, 2017, 11:36:53 AM

News regarding Softwood products by vox
April 19, 2017, 10:44:13 AM

Linux probs on x1000 Southern Islands by vox
April 19, 2017, 10:41:14 AM

Gold2 for Vampire/Apollo released by vox
April 19, 2017, 10:28:49 AM

REV'n'GE! #73 by Seiya
April 15, 2017, 06:50:29 PM

Amiga Future monatliche News März 2017 by AndreasM
March 29, 2017, 04:30:13 PM

REV'n'GE! #72 by Seiya
March 15, 2017, 05:48:30 PM

Amiga Future Ausgabe 125 erschienen by AndreasM
March 02, 2017, 03:22:24 PM

REV'n'GE! #71 by Seiya
February 15, 2017, 07:30:32 PM

Amiga Future monatliche News Januar 2017 by AndreasM
January 31, 2017, 02:48:26 PM

SMF Links ezBlock

Amiga Developer Wiki
MorphOS Programmer's Handbook
Hyperion AmigaOS 4 support forum
TAWS
Powered by EzPortal