Amigaforum

Please login or register.

Login with username, password and session length
Advanced search  

News:

SMF - Just Installed!

+- +-

+-User

Welcome, Guest.
Please login or register.
 
 
 
Forgot your password?

+-Stats ezBlock

Members
Total Members: 149
Latest: arti110
New This Month: 0
New This Week: 0
New Today: 0
Stats
Total Posts: 1313
Total Topics: 323
Most Online Today: 78
Most Online Ever: 140
(May 28, 2017, 04:25:45 AM)
Users Online
Members: 0
Guests: 64
Total: 64
Pages: [1]   Go Down

Author Topic: Linux probs on x1000 Southern Islands  (Read 381 times)

0 Members and 1 Guest are viewing this topic.

vox

  • Jr. Member
  • **
  • Karma: +2/-3
  • Posts: 99
    • View Profile
Linux probs on x1000 Southern Islands
« about: April 19, 2017, 10:41:14 AM »

Hi gents!

A bit late and resistant but finally purchased Enhancer and Radeon 7000HD (since W3D for Radeon 6000HD, Timberwolf updated and promise of Libre port have turned me on to buy x1000).

I still find it morally degrading to buy FE, Enhancer and new video card to get system bugfixed
and Warp3D ready (since we have prepaid OS 4.2, RadeonHD driver of that time and x1000 was
sold as "system" but sic, gfx cards in that system were to complex to 3D support), but hey, its Amiga.

On AmigaOS side things got brighter with Enhancer, but Linux side has been challenging.

a) Seems most of net installs, x1000 Ubuntu 12 CD etc. were all built for NI cards. Mostly Linuxes install, but fail to bring GUI. Kernel loads, everything looks OK, init gui and ... they are stuck. And those are x1000 supported. Out of stock netinstall initrd.gzs usually fail at partition time, unable to read partitions.

b) I have managed to install only older Debian 7 net install, however in KDE 4.x even with Compiz install it does not have OpenGL

c) Not everything is equal to CFE. I am unable to boot kernel from affs (old file system)
BDH0: or from EXT2 Linux boot partition. Is ide0.1:vmlinuz enough or somehow should
pont to SDB5

CF card is out now, had probs with 4GB one, AOS was unable to read 4GB FAT16
and CFE would also quirk rendering it unreadable from time to time. Switching
back to old good 128MB.

One sidenote, I do have classic HDD as data slave and SDD as primary.
I am aware that x1000 cant boot from every other device.

Also when expanding memory, take note that memory size needs to be set in
CFE (see memory= in printenv variables). Sad sad and buggy CFE.
Logged
Pages: [1]   Go Up
 

+-SMF Gallery Random Image

Recent Topics ezBlock

REV'n'GE! #76 by Seiya
July 19, 2017, 07:26:16 PM

Amiga Future Ausgabe 127 erschienen by AndreasM
July 02, 2017, 01:47:54 PM

Amiga Future monatliche News Juni 2017 by AndreasM
June 27, 2017, 05:12:01 PM

REV'n'GE! #75 by Seiya
June 16, 2017, 06:40:59 PM

Amiga Future monatliche News Mai 2017 by AndreasM
May 31, 2017, 10:51:31 AM

REV'n'GE! #74 by Seiya
May 18, 2017, 04:17:45 PM

Amiga Future Ausgabe 126 erschienen by AndreasM
May 04, 2017, 08:30:08 AM

Roadshow 1.13 released by AndreasM
May 02, 2017, 06:35:49 AM

Amiga Future monthly News April 2017 by AndreasM
April 30, 2017, 12:12:32 PM

Amiga Future Everywhere: Android App erschienen by AndreasM
April 20, 2017, 11:36:53 AM

SMF Links ezBlock

Amiga Developer Wiki
MorphOS Programmer's Handbook
Hyperion AmigaOS 4 support forum
TAWS
Powered by EzPortal